Opened 6 years ago

Closed 6 years ago

#9237 closed bug (invalid)

Datepicker not closing when in iFrame, using Firefox browser

Reported by: bongobongo Owned by: bongobongo
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I'm using the Datepicker in an iFrame. NOTE: The page in the iFrame is from another domain, than parent page.

It will not close when date is clicked, or when clicked outside the datepicker. Issue in Firefox, not in Chrome.

Currently I made a workaround when the date is clicked like this:

onSelect: function(selectedDate) {
   $('#ui-datepicker-div').hide();
}

Obviously this does not fix issue when user click outside the Datepicker.

Using: jquery-1.9.1.min.js jquery-ui-1.10.1.custom.min.js

Change History (4)

comment:1 Changed 6 years ago by tj.vantoll

Owner: set to bongobongo
Status: newpending

Hi bongobongo,

Thanks for taking the time to contribute to the jQuery UI project. In order to assess this ticket we're going to need a reduced test case that shows this problem. You can use this as a starting point: http://jsfiddle.net/tj_vantoll/tRdpr/.

To test iframes you can point one jsFiddle at another's results, see http://jsfiddle.net/tj_vantoll/s5g2u/. The same trick can be done with JS Bin if you prefer it.

Thanks.

comment:2 Changed 6 years ago by bongobongo

Status: pendingnew

Thanks for those links!

Did the test using: jsfiddle and JS Bin. Unable to reproduce problems there. Will do some more tests on monday on my script...

comment:3 Changed 6 years ago by tj.vantoll

Status: newpending

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.