Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9275 closed bug (duplicate)

Auto width in dialogs does not take the length of title into consideration

Reported by: rexcfnghk Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

As shown in the fiddle, the width property has been set to "auto" but the title of the dialog cannot be viewed in full without resizing

http://jsfiddle.net/UgV2p/

Change History (2)

comment:1 Changed 7 years ago by Scott González

Component: ui.coreui.dialog
Resolution: duplicate
Status: newclosed

Duplicate of #4437.

comment:2 Changed 6 years ago by jasimon9

Ticket #4437 applies to IE6/IE7. I have found this problem to occur in IE11 and current versions of Firefox and Chrome as of 26-Jan-14. Therefore it is not a duplicate of that ticket, which is set as "wont'fix", which makes sense relative to the old IE versions.

I found this problem after upgrading from jqueryui 1.8.16 to 1.10.3. Titles which previously were displayed in full are now truncated with the added ellipsis.

To compensate I have added a fixed width. In my case, the width is defaulting to 300; I have to make that 350 for the truncation of the title to be avoided.

So the workaround is the add the width. Ideally, you would only set the width where the truncation occurs by adding an extra function parameter, but I would hope rather for a corrected computation in the dialog widget to avoid a lot of otherwise unnecessary overriding.

Note: See TracTickets for help on using tickets.