Opened 7 years ago

Closed 7 years ago

#9279 closed bug (duplicate)

Empty List sorting difficulty (Horizontal, float:left joined lists)

Reported by: attheicearcade Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Tested in Firefox 20.0.1 on Win 7 + XP and Chrome Version 26.0.1410.64 on Win 7 using jQuery UI 1.9.2 and 1.10.2

JSFiddle: http://jsfiddle.net/jfcgN/2/

Situation: 2 connected sortable lists with li float:left are hard to sort under specific conditions described in the JSFiddle

Expected behaviour: When items are moved to the empty second list and reordered, it should behave the same as the first list.
Actual behaviour: The list becomes very difficult to reorder precisely, unlike the first list.

This behaviour only occurs on float: left <li> items moved from within the second list and over the second list. Items grabbed from the first list and moved over the second list work as expected (as of jQuery UI 1.10.2). It is also fixed by adding a list item to the second list.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7498.
This happens because the internal floating check occurs at creation and assumes that if a list is empt, it is not floating. As a hacky workaround you can set the internal flag after initialization: http://jsfiddle.net/tj_vantoll/Xs8xu/.

Note: See TracTickets for help on using tickets.