Opened 6 years ago

Closed 5 years ago

#9325 closed bug (duplicate)

Draggable: helpers do not account for margin on draggable element

Reported by: ComFreek Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Test case: http://jsfiddle.net/YtNCu/

jQuery version: 1.9.1 jQuery UI version: 1.10.3

Tested systems Windows 8 Pro 64-bit:

  • Chrome 27.0.1453.94 m
  • IE 10
  • [Works as expected!] Safari 5.1.7
  • [Works as expected!] Opera 12.15

Unfortunately, I could not test Firefox/Aurora because a) they don't load jsFiddle (loading image forever), b) they aren't able to load local files using jQuery CDNs and c) I do not have time for further researchs ;)

Change History (3)

comment:1 Changed 6 years ago by tj.vantoll

Status: newopen
Summary: Wrong draggable start position when using auto margin.Draggable: helpers do not account for margin on draggable element

It doesn't have to be margin: auto, any margin placed on the helper will not be accounted for: http://jsfiddle.net/tj_vantoll/zB2w9/. You can work around this by using the cursorAt option.

comment:2 Changed 5 years ago by mikesherov

Margin: auto has issues in specific browsers in that some will return an actual pixel value, while others still will return "auto". There's unfortunately nothing we can do about that.

However, in the case of specific margin values, I suppose we can adjust by the offset of the helper relative to the original? Not sure how this specifically this would work, but worth eploring further.

comment:3 Changed 5 years ago by mikesherov

Resolution: duplicate
Status: openclosed

Duplicate of #7853.

Note: See TracTickets for help on using tickets.