Opened 7 years ago

Closed 7 years ago

#9333 closed bug (duplicate)

autocomplete and datepicker different behaviours inside dialogs

Reported by: aNt1X Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

if you play a little with this fiddle http://jsfiddle.net/Nb76L/ you will notice that autocomplete and datepicker behave in two different ways when used inside dialogs.

I notice that:

  • if you drag the dialog window, the datepicker closes itself, while the autocomplete follows the dialog
  • datepicker is always appended to "body", while autocomplete by default is appended to the element container
  • if you set the "appendTo: $('body')" option to the autocomplete to make it behave like datepicker, it will not behave correctly (to me, it shows on the back of the dialog, using chrome 27.0.1453.94 m).

I think that the two elements should behave the same way, and personally i prefer the DatePicker behaviour, this is why i opened this ticket as an autocomplete bug.

I'm playing with the appendTo option because in my application when the autocomplete is created inside a jqdialog (used by jqgrid) it is cut inside the boundaries of the jqdialog.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6642.
Actually, we'll be implementing the autocomplete logic in datepicker, as that's how every other stacking element works. See #9013 for datepicker and #6642 for the non-closing autocomplete problem.

Note: See TracTickets for help on using tickets.