Opened 6 years ago

Closed 6 years ago

#9360 closed bug (invalid)

Tabs and iPhone

Reported by: mattias.nilsson Owned by: mattias.nilsson
Priority: minor Milestone: none
Component: ui.tabs Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have a problem when trying to render my tabs structure on an iPhone. The problem is that sometimes I click on one of the items and it gets triggered twice.

This works out 4 out of five times and it is not consistent. In my opinion this is related to a event handler problem.

HTML Structure:

<div class="footer-top">
<div class="container-12">
<ul>
<li><a href="#headline">Headline 1</a></li>
<li><a href="#headline-two">Headline TWO</a></li>
</ul>
<div id="headline">Headline 1 CONTENT</div>
<div id="headline-two">Headline TWO CONTENT</div>
</div>
</div>

Javascript:

var accordionTabs = function(elements) {
		$(elements).tabs({
			collapsible: true,
			active: false,
			beforeActivate: function(event, ui){
				if ($(ui.oldTab).length > 0) {
					$(ui.oldTab).height(54);
				}
				$(ui.newTab).height($(ui.newPanel).height());
			}
		});
	};

Change History (2)

comment:1 Changed 6 years ago by tj.vantoll

Owner: set to mattias.nilsson
Status: newpending

Hi mattias.nilsson,

Thanks for taking the time to contribute to the jQuery UI project. I'm not seeing the issue you're describing: http://jsfiddle.net/5ufWm/. The event handler is consistently only firing once on iOS 6.

Can you please alter my test case to show the issue you're seeing? Thanks.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.