Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9368 closed bug (worksforme)

datepicker wrong initialization-language

Reported by: dmack Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

After creation the datepicker-element with a specific language :

$(selector).datepicker($.datepicker.regional[ "YOURLANGUAGEHERE" ]);

the first shown calendar-page is still in english - if you change the month (for example), the chosen language is used. Im guessing this is because of a missing step during the initializiation-process of datepicker -- if a language is given, the picker certainly should display the first page in that language

Change History (12)

comment:1 Changed 6 years ago by Scott González

Resolution: worksforme
Status: newclosed

This is working just fine for me. If you're still having problems, please create a reduced test case using jsbin or jsFiddle that shows the problem and we will re-open this ticket.

comment:2 Changed 6 years ago by Scott González

Component: ui.coreui.datepicker

comment:3 Changed 6 years ago by dmack

sorry but you have obviously not tested it at all : http://jsfiddle.net/CeRys/

comment:4 Changed 6 years ago by Scott González

On that page, I get a perfectly working datepicker using the specified locale: http://cl.ly/image/2b0d3p2m0V09

comment:5 Changed 6 years ago by dmack

you definitely modified it of sorts, see screenshot http://im.bilderkiste.org/1137078342251/nope.PNG

comment:7 Changed 6 years ago by dmack

and IE doesnt seem to work AT ALL .... there is definitely something wrong with either jsfiddle or JQuery UI http://im.bilderkiste.org/3137078399063/nope3.PNG

comment:8 Changed 6 years ago by dmack

on google chrome MOBILE, it seems to work. That is weird. http://im.bilderkiste.org/1137078438105/Screenshot_2013-06-09-15-22-11.png

comment:9 Changed 6 years ago by dmack

IE has some issues with JSFiddle - JSBin works in IE, but the datepicker still isnt regional http://jsbin.com/irijoc/1/edit http://im.bilderkiste.org/8137078550935/IE.PNG

comment:10 Changed 6 years ago by Scott González

This is clearly not a problem with jQuery UI. Also, you should really not use GitHub files as <script> source since they're never transferred with the correct MIME type.

comment:11 Changed 6 years ago by dmack

so what you're saying is that a problem which renders JQuery-UI incompatible with nearly every browser for this specific widget is not a problem of JQuery UI? That doesnt make any sense at all.

comment:12 Changed 6 years ago by Scott González

The code works everywhere. The problem is completely unrelated to the code or files that we're providing. Go to the fourms. You won't receive any more responses on this bug tracker.

Note: See TracTickets for help on using tickets.