Opened 7 years ago

Closed 7 years ago

#9378 closed bug (duplicate)

jQuery UI Dialog incompatible with TinyMCE 4

Reported by: youeyesee Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

I originally posted this on the TinyMCE bug tracker, but they are claiming it's a jQuery UI problem. Here is the link to the bug on the TinyMCE bug tracker site: http://www.tinymce.com/develop/bugtracker_view.php?id=5917 There the claim is made: "jQuery UI [is] binding some form of event blocker on everything within it".

Steps to reproduce:

  1. Put a TinyMCE Version 4 with the Link plugin inside of a JQuery UI dialog.
  2. Try to add a hyperlink, or remove an existing hyperlink.
  3. Notice that you can't set focus to the textbox in the Link popup.

Take a link at the fiddle example I created: http://fiddle.tinymce.com/Fhdaab/3

Reproduced with Firefox, Chrome and Safari on a Mac.

On IE you can type in the box but you can't create an hyperlink using selected text because it deselects the text when the popup opens. Also, because of that reason you can't use it to remove a link.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9087.

Note: See TracTickets for help on using tickets.