Opened 6 years ago

Last modified 4 years ago

#9391 reopened bug

Autocomplete: selection doesn't work well on Android 4.2

Reported by: Thrys Owned by: Thrys
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Concerned Versions :

  • JQuery UI : 1.10.3
  • Android : 4.2.2
  • Chrome : 27.0.1453.90
  • Smartphone : Nexus 4 / JDQ 39
  • WebKit : 537.36
  • V8 : 3.17.6.14

To reproduce :

  1. Go to public demo with the smartphone : http://jqueryui.com/autocomplete/
  2. Tape 'P' in the field (the proposals appear)
  3. Select for example 'PHP"
  4. The autocomplete select 'ActionScript'

Normaly we attempt that the selected element appear in the field.

PS : We don't use the jquery mobile autocomplete because it's modify the hash of the url, which damage the routing of our MVC framework.

Change History (9)

comment:1 Changed 6 years ago by tj.vantoll

Owner: set to Thrys
Status: newpending

Hi Thrys,

Thanks for taking the time to contribute to the jQuery UI project. I was unable to recreate this with a Android 4.2.x tablet or a Android 4.1.x phone. I can have some other people on the team give this a shot.

Do you see the issue on the demo page directly: http://jqueryui.com/resources/demos/autocomplete/default.html?

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by Thrys

Sorry for the delay. I just try the issue on the demo page (http://jqueryui.com/resources/demos/autocomplete/default.html) I have the same problem with the same configuration. To reproduce the problem, I fill "p" in the field and when I click on "Python", the component choose "Perl", when I click on "PHP", it chose "Lisp", for "Perl" it chose "JavaScript".

The behevior it's like if the component select the item two levels above.

comment:4 in reply to:  3 Changed 6 years ago by tj.vantoll

Replying to Thrys:

Sorry for the delay. I just try the issue on the demo page (http://jqueryui.com/resources/demos/autocomplete/default.html) I have the same problem with the same configuration. To reproduce the problem, I fill "p" in the field and when I click on "Python", the component choose "Perl", when I click on "PHP", it chose "Lisp", for "Perl" it chose "JavaScript".

The behevior it's like if the component select the item two levels above.

I still cannot recreate this but I can have some others try it out.

comment:5 Changed 6 years ago by tj.vantoll

Resolution: invalid
Status: closedreopened
Summary: The autocomplete selection doesn't work well on Android 4.2Autocomplete: selection doesn't work well on Android 4.2

Looks like we were able to recreate this, but it appears to happen sporadically. Also I couldn't recreate this on a Nexus 7 running Android 4.2.x.

comment:6 Changed 6 years ago by Thrys

I don't know if this problem is linked to the first, but on Firefox for mobile Version 21.0 the component doesn't work of all.

For reminder the configuration :

  • JQuery UI : 1.10.3
  • Android : 4.2.2
  • Firefox : 21.0
  • Smartphone : Nexus 4 / JDQ 39

To reproduce this "new" problem, tape what you want in the field, try to select an item and the component display nothing.

PS : I can create an other issue for this problem ?

comment:7 in reply to:  6 Changed 6 years ago by tj.vantoll

Replying to Thrys:

I don't know if this problem is linked to the first, but on Firefox for mobile Version 21.0 the component doesn't work of all.

For reminder the configuration :

  • JQuery UI : 1.10.3
  • Android : 4.2.2
  • Firefox : 21.0
  • Smartphone : Nexus 4 / JDQ 39

To reproduce this "new" problem, tape what you want in the field, try to select an item and the component display nothing.

PS : I can create an other issue for this problem ?

If you think it's a completely unrelated problem then you can create a new issue, although it sounds like this might be the same thing. I'll give this a shot later tonight and see if I can recreate this in Firefox.

comment:8 Changed 6 years ago by tj.vantoll

The component works fine for me using Firefox 23 on a Nexus 7 running Android 4.2.2.

comment:9 Changed 4 years ago by ryanll

I've just come across this issue, on selection does not work (data source is Ajax)

jQuery: 1.9.1 jQuery UI: 1.10.4 stock browser of Android 4.0.3

Also tried http://jqueryui.com/autocomplete/ and having same problem.

Does NOT happen on different browser (Chrome, Firefox) on the same phone

Note: See TracTickets for help on using tickets.