Opened 6 years ago

Closed 6 years ago

#9436 closed bug (invalid)

jQuery UI Datepicker Month & Year Menus Only Work Once

Reported by: ryanburnett Owned by: ryanburnett
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

  • The version(s) of the jQuery project that are affected. All (using 2.0.2 in jsfiddle, below)
  • The browser (or browsers) that you are able to reproduce the bug in, including version numbers. Latest versions of Chrome (28.0.1500.72), Firefox (22.0) and IE (10.0.9200.16635).
  • The operating system (or operating systems) you experienced the bug on. Windows 7 Professional
  • Step-by-step instructions on how to reproduce the issue, including any required system configuration changes.

I'm using jQuery UI's month and year menus. Here's what's happening and where I'm running into an issue:

  • Click the date field
  • Change the month dropdown to Jan
  • Change the year dropdown to 2003
  • Click the calendar day 1
  • The date field is correctly populated with 01/01/2003

Here's where I run into the issue:

  • Click the date field (again)
  • Change the month (or year) dropdown
  • The date does not change
  • Click off of the datepicker to hide it
  • The date still does not change

Here's my fiddle

  • A description of what you expect to happen, and what actually happens.

I expect the month and year dropdown to change the date, even after a date has been entered.

I appreciate your help. Keep up the great work!

Change History (2)

comment:1 Changed 6 years ago by Scott González

Owner: set to ryanburnett
Status: newpending

Changing the month or year dropdowns isn't supposed to change the selected date. You have to actually select a date for the date to change. The datepicker is updating as I would expect.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.