Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9443 closed bug (duplicate)

Can't move later added items to last position on initially empty floating sortable with {axis: x} option

Reported by: gentooboontoo Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Bug triggered because floating detection returns always false when sortable is initially empty.

JSFiddle demo: http://jsfiddle.net/gentooboontoo/8dRdp/6/

Change History (4)

comment:1 Changed 7 years ago by gentooboontoo

Pull request with fix and associated test: https://github.com/jquery/jquery-ui/pull/1035

comment:2 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7498.
This is part of a bigger problem in that "floating" is only determined during creation and not updated by the refresh method.

While your fix does work for this specific case, I'd prefer we land something that will generically solves the problem. gentooboontoo, would you be interested in looking into that?

comment:3 Changed 6 years ago by tj.vantoll

#10083 is a duplicate of this ticket.

comment:4 Changed 6 years ago by tj.vantoll

Note: See TracTickets for help on using tickets.