Opened 7 years ago

Closed 7 years ago

#9447 closed bug (duplicate)

Dialog window dragging after initial page load

Reported by: mrahmani Owned by: mrahmani
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

After downloading a JQuery UI (ui-darkness for example) I unzipped the content in the download folder (I am using windows 7 64bit) and launched the "index.html" demo page. Before doing anything else with the other widgets I clicked on the "open dialog" link and when the dialog window opened I tried to move the dialog around, it slipped down the screen, I had to scroll down to find it.

Change History (6)

comment:1 Changed 7 years ago by tj.vantoll

Owner: set to mrahmani
Status: newpending

Hi mrahmani,

Thanks for taking the time to contribute to the jQuery UI project. I just tried this out on Windows 7 in IE9 and Firefox and could not recreate any issues. What browser are you using and can you recreate this problem in other browsers?

comment:2 in reply to:  1 Changed 7 years ago by mrahmani

Status: pendingnew

Hi tj.vantoll,

Thanks for your response, I could not reproduce the slipping-down behavior in Firefox. I am using IE10 now but I had the same issue in IE9 as well. As I mentioned before, this behavior only occurs when the page is first opened and the "open dialog" is the first to be clicked, then, when I grab the dialog window to drag it around, it slips down and hides.

comment:3 Changed 7 years ago by Scott González

Status: newpending

Does the error occur for you on this page? http://view.jqueryui.com/1.10.3/demos/dialog/modal-form.html

If not, are you able to create a jsFiddle that does exhibit the broken behavior? You can use http://jsfiddle.net/tj_vantoll/vwk3D/ as a starting point.

comment:4 in reply to:  3 Changed 7 years ago by mrahmani

Status: pendingnew

Hi Scott,

No, the error does not occur on the demos page, however it occurs on both IE10 and Firefox on the theme roller page http://jqueryui.com/themeroller/, there is a Dialog button right after the Tabs. If you can't see it on this page then it must be something wrong with my system and you can just ignore this bug report.

Regards, Mouloud.

comment:5 Changed 7 years ago by dlbeswick

Hi, I'm also seeing this behaviour and reproduced it in the fiddle below.

http://jsfiddle.net/dlbeswick/u7RkV/1/

Just scroll down the page a bit, then try dragging the dialog. You should see the behaviour described in the bug.

comment:6 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9315.
Both http://jqueryui.com/themeroller/ and http://jsfiddle.net/dlbeswick/u7RkV/1/ point to this being a duplicate of #9315.

Note: See TracTickets for help on using tickets.