Opened 7 years ago

Closed 7 years ago

#9450 closed bug (duplicate)

first tab is considered "special" by design - it's a bug.

Reported by: PawelRoman Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

When user clicks on a tab beforeActivate event is fired for the tab.

When tab "clicks itself" only because it HAPPENS to be the first tab - the event is not fired. The only way to do something is to use create() event. Why are there 2 events to do the same thing? Only because some <li> HAPPENS to be first - it should not be handled specifically. What if I change order of tabs and some other tab becomes first tab - my code will stop working.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8735.
Please don't intentionally file duplicate tickets. What you're saying about your code suddenly not working is false. Please ask for help on the forums if you're actually having an issue with some code you wrote.

Note: See TracTickets for help on using tickets.