Opened 8 years ago

Closed 8 years ago

#9454 closed bug (duplicate)

Datepicker getDate API call with 29 February

Reported by: hugi Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

I found a problem with the getDate API call from Datepicker. If I enter 29 February in the date input text field the getDate method will return a different date.

I tested it with version 1.10.3 and version 1.9.2.

To simulate the bug please use this fiddle: http://jsfiddle.net/ebqFs/

  1. Insert 29th February 2012 in the input field
  2. Loose focus of the Datepicker UI element. (click somewhere)
  3. Get focus of the Datepicker UI element. (click input field)

=> Date change to today

Thanks for your help!

Change History (1)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #7759.

Note: See TracTickets for help on using tickets.