Opened 7 years ago

Closed 7 years ago

#9461 closed bug (duplicate)

Draggable: cloned helper is off-position when scrolled

Reported by: Bob Stein, VisiBone Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Reappearance of bug #3740 ?

Instructions:

  1. Firefox
  2. http://jsfiddle.net/wsHej/
  3. Drag the IMG. Notice how the clone starts on top of the original.
  4. Scroll the Result area down a little. You may have to make the window smaller in order to see the scrollbars on this area.
  5. Now try to drag the IMG. The clone starts down way down below the original -- apparently as far below the original as you scrolled.

Broken in jQuery 2.0.2 jQuery-UI 1.10.3 (see in jsfiddle) using Firefox 12 or 22. Fine in Chrome 28.

Other versions:

Broken in jQuery 1.10.2 jQuery-UI 1.10.3 (not available in jsfiddle)

Fine in jQuery 1.9.1 jQuery-UI 1.9.2 (try in jsfiddle)

Fine in jQuery 1.7.2 jQuery-UI 1.8.18 (try in jsfiddle)

Screen Shot, working: http://visibone.com/javascript/jquery/workingDraggable.png

ScreenShot, broken: http://visibone.com/javascript/jquery/brokenDraggable.png

Change History (2)

comment:1 Changed 7 years ago by Bob Stein, VisiBone

Simple example showing bug with both scrollbars: http://jsfiddle.net/t9mMQ/ (Scroll down and to the right, then drag the image. Again, use Firefox.)

comment:2 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9315.

Note: See TracTickets for help on using tickets.