Opened 6 years ago

Closed 6 years ago

#9466 closed bug (duplicate)

jQuery UI dialog closes in IE 10 when clearing value of inner input field

Reported by: Quh Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery version : 2.0.3 jQuery UI version : 1.10.3 IE version : 10 (Win 8)

It's a private just-for-fun project I'm working on, so I don't have the time and ressources to test the descriped behaviour with other versions of jQuery/UI or IE.

The bug I experienced is pretty simple - I have a dialog with an inner input field. In an event I'm clearing the value of the input field. And somehow the whole dialog is closed.

<!DOCTYPE html>
<html>
	<head>
		<title>Dialog-Test</title>
		<link rel="stylesheet" type="text/css" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.10.3/themes/redmond/jquery-ui.min.css">
		<script src="http://ajax.googleapis.com/ajax/libs/jquery/2.0.3/jquery.min.js" type="text/javascript"></script>
		<script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.10.3/jquery-ui.min.js" type="text/javascript"></script>
		<script type="text/javascript">
			$(function() {
				$('#dialog').dialog({
					
				});
				
				$(document).on('keydown','.dialog_event',function(event) {
					if(event.which === 13) {
						$(this).val('');
					}
				});
			});
		</script>
	</head>
	<body>
		<div id="dialog">
			<input type="text" class="dialog_event">
		</div>
	</body>
</html>

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9312.

Note: See TracTickets for help on using tickets.