Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9498 closed feature (invalid)

Resizable: multiple handles for same direction not supported

Reported by: barhorn Owned by: barhorn
Priority: minor Milestone: none
Component: ui.resizable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

If multiple handles are defined for the same direction (ex: "w", "ne", etc), then only the first one is ever taken into consideration.

Here's the fiddle: http://jsfiddle.net/2zFMU/4/

The fix is actually quite simple:

in jquery.ui.resizable.js around line 253 (jQueryUI v1.10.3), we should loop over the handles object instead of just grabbing the first one. ie, change:

::removed::

Change History (7)

comment:1 Changed 6 years ago by Scott González

Description: modified (diff)
Owner: set to barhorn
Status: newpending
Type: bugfeature

This is not a bug, but a feature request. Can you please explain the real use case for this?

comment:2 in reply to:  1 Changed 6 years ago by barhorn

Status: pendingnew

Replying to scott.gonzalez:

This is not a bug, but a feature request. Can you please explain the real use case for this?

Sure. It's similar to the jsFiddle. Basically, we have a specific element that is overloaded with a number of functionalities: drag the handle left/right to resize the Resizable, click it to open/close the resizable, etc. However, users also want to be able to drag the edge of the Resizable element in order to resize it, but they don't want to get rid of the functionality of the tab/handle that is there either. Therefore we need multiple handles to resize the element.

comment:3 Changed 6 years ago by Scott González

Status: newpending

Why can't you just nest? http://jsfiddle.net/2zFMU/5/

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 6 years ago by barhorn

Comment to keep this ticket open. Would still like to see this minor feature added....

comment:6 Changed 6 years ago by Scott González

You haven't answered the question.

comment:7 in reply to:  6 Changed 6 years ago by barhorn

Replying to scott.gonzalez:

You haven't answered the question.

Sorry, I missed your suggestion. In my particular case, you are probably correct: I could just nest to get the desired effect. I just don't see the reason in the resizable code to limit the handle to be a single element (by grabbing the first one) rather than multiple.

If I'm the only person that has ever brought this up, go ahead and close this ticket. Your suggestion will work for my current use case. Thanks!

Note: See TracTickets for help on using tickets.