Changes between Initial Version and Version 1 of Ticket #9515


Ignore:
Timestamp:
Aug 26, 2013, 4:07:03 PM (7 years ago)
Author:
Scott González
Comment:

The spinner never adjusts a manually entered value. I've filed an issue to get this properly documented: https://github.com/jquery/api.jqueryui.com/issues/161

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9515

    • Property Status changed from new to closed
    • Property Resolution changed from to notabug
    • Property Summary changed from spinner does not add currency symbol after value entered by keypress to Spinner does not add currency symbol after value entered by keypress
  • Ticket #9515 – Description

    initial v1  
    11When a spinner is set for currency and a user sets value to zero i.e. £1.00 to 0 (note the pound symbol is now missing) the spinner control does not replace the currency symbol after keydown or keypress or blur. However by using keyup or keydown to change the value will reformat the value and bring back the currency symbol.
    22If this is by design then maybe an option that makes the currency symbol fixed in place would be useful.
    3 
    4 A simple fix I have applied on line 13513:
    5 _keydown: function( event ) {    // EXISTING CODE
    6  var options = this.options,     // EXISTING CODE
    7  keyCode = $.ui.keyCode;         // EXISTING CODE
    8 
    9 var value = this.value() || 0;
    10 this._value(value);
    11