Opened 6 years ago

Closed 6 years ago

#9536 closed bug (duplicate)

Position: incorrectly calculates collision bounds when transformations applied

Reported by: DarkSerg Owned by:
Priority: minor Milestone: none
Component: ui.position Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

When using position method on elements which have css transformations applied (eg. rotate or scale) and enabling collisions detection will result in wrong bounds detection.

See example here: http://jsfiddle.net/XPZay/5/

Drag the green box to the right or bottom border of the window. You will see it detects bound of transformed elements by original box.

And here is the second issue. Chrome makes transformation after position of target element was set. Result is initial position is wrong. But it fixed after you click or drag the parent. Not sure if it's either Chrome or UI bug.

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #6844.

Note: See TracTickets for help on using tickets.