Opened 6 years ago

Closed 5 years ago

#9539 closed bug (invalid)

1.11.0 (git) -- Recent ui.mouse change on git breaks ui.draggable on iPad

Reported by: johnnyshields Owned by: johnnyshields
Priority: minor Milestone: none
Component: ui.mouse Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

This commit:

https://github.com/jquery/jquery-ui/commit/24756a978a977d7abbef5e5bce403837a01d964f#commitcomment-4024417

in ui.mouse.js line 117:

Iframe mouseup check - mouseup occurred in another document else if ( !event.which ) {

return this._mouseUp( event );

}

These added lines break ui.draggable on iPad (I'm using touch punch). Previously, dragging worked as expected on iPad. After adding these lines, when I touch a draggable element, draggable appears to start but then immediately stop.

Removing the lines listed above fixes the issue.

Change History (7)

comment:1 Changed 6 years ago by johnnyshields

Code above is formatted incorrectly. The affected lines are:

    // Iframe mouseup check - mouseup occurred in another document
    else if ( !event.which ) {
      return this._mouseUp( event );
    }
Last edited 6 years ago by johnnyshields (previous) (diff)

comment:2 Changed 6 years ago by tj.vantoll

Owner: set to johnnyshields
Status: newpending

To be clear here, you're not seeing an issue with jQuery UI itself, just that the changes made in git have broke touch punch - correct?

comment:3 Changed 6 years ago by johnnyshields

Status: pendingnew

I have not observed an issue on non-mobile platforms, but have not tested extensively. Regardless, touch-punch is widely used and this should be fixed before release. It's likely that these lines will impact similar mobile frameworks.

Last edited 6 years ago by johnnyshields (previous) (diff)

comment:4 Changed 6 years ago by tj.vantoll

Status: newpending

I'm not seeing this issue on iOS6 - http://jsfiddle.net/tj_vantoll/38UFh/.

Can you please alter my test case to show the issue you're experiencing?

comment:5 Changed 6 years ago by johnnyshields

Status: pendingnew

Huh I played around with it but couldn't reproduce on JS Fiddle. Bizarre...

I'll have to take deeper look at what's going on in my app, will need awhile for this.

comment:6 Changed 6 years ago by tj.vantoll

Status: newpending

Ok, if you can get a make reproducible test case we can investigate.

comment:7 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.