Opened 4 years ago

Closed 17 months ago

#9541 closed feature (fixed)

Button: Use control.labels if available

Reported by: scottgonzalez Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.button Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Change History (4)

comment:1 Changed 4 years ago by scottgonzalez

  • Status changed from new to open

We can check the control property without doing any feature detection. If the result is undefined, then we need to query for the associated control. If it's null, then there is no associated control.

comment:2 Changed 4 years ago by scottgonzalez

  • Description modified (diff)
  • Summary changed from Button: Use label.control if available to Button: Use control.labels if available

Turns out we always search in the opposite direction. Updating to use control.labels instead of label.control.

comment:3 Changed 3 years ago by jzaefferer

This is being implemented in the button rewrite: https://github.com/jquery/jquery-ui/pull/1216

comment:4 Changed 17 months ago by scottgonzalez

  • Milestone changed from none to 1.12.0
  • Resolution set to fixed
  • Status changed from open to closed

Confirmed fixed in master.

Note: See TracTickets for help on using tickets.