Opened 6 years ago

Closed 5 years ago

#9578 closed bug (invalid)

Dialog: Overlay background incorrect in android browser

Reported by: groupboard2 Owned by: groupboard2
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Go to http://taitems.github.io/Aristo-jQuery-UI-Theme/ in android browser and click 'open modal dialog'. Zoom in and out of page with pinch zoom. You'll see that the grey modal background is screwed up until you try scrolling. Works perfectly on chrome browser.

Change History (6)

comment:1 Changed 6 years ago by tj.vantoll

Owner: set to groupboard2
Status: newpending

Hi groupboard2,

Thanks for taking the time to contribute to the jQuery UI project. Are you seeing the behavior here http://jsfiddle.net/tj_vantoll/QFp2J/show/?

Also what version of Android are you using?

Thanks.

comment:2 Changed 6 years ago by groupboard2

Status: pendingnew

Yes, the bug occurs there (although not quite as easy to recreate). If you rotate to landscape you'll see a big white rectangle on the left hand side. Using Android 4.1.2 on a samsung galaxy note.

comment:3 Changed 6 years ago by tj.vantoll

Component: ui.coreui.dialog
Status: newopen
Summary: modal dialog background incorrect in android browserDialog: Overlay background incorrect in android browser

comment:4 Changed 6 years ago by Alexander Schmitz

This is not a bug this is how android works because you have not set a viewport meta tag the android browser zooms to what it thinks is a good level when the page loads and then it zooms to a new "good" level when you change orientation. But zooming a fixed position element actually scale elements in android browser ( creating the whitespace you see ). if you set a viewport meta tag like this to enforce the initial scale <meta name="viewport" content="width=device-width, initial-scale=1"> you will not see this problem any more ( unless you zoom ) While this is less then ideal its just how android decided to implement fixed positioning.http://jsbin.com/ukUvAVUR/6/edit using that meta tag no longer exhibits this issue.

comment:5 Changed 6 years ago by Jörn Zaefferer

Status: openpending

groupboard2, can you confirm that using the meta tag would solve the problem for you?

comment:6 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.