Opened 6 years ago

Closed 6 years ago

#9596 closed bug (worksforme)

DatePicker With range changing the from date on select of to date and viceversa

Reported by: sadashiv Owned by: sadashiv
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

I checked the demo at http://jqueryui.com/datepicker/#date-range and found that when I select a from date and then a to date and again change the to date then the from date gets changed.

Sometimes if I set the from date then the same date is copied as the end date. I am using latest version of google chrome.

Change History (6)

comment:1 Changed 6 years ago by Scott González

Owner: set to sadashiv
Status: newpending

I'm not seeing this behavior. Can you please give specific steps for reproduction?

comment:2 Changed 6 years ago by sadashiv

Status: pendingnew

I was able to replicate the issue using steps as

1) Open date range example 2) Select from date (sometimes the to date is also set to the same value) 3) Select to date and again change the to date (now the from date gets changed)

I too can't replicate this everytime but can replicate this few times

comment:3 Changed 6 years ago by Scott González

I'm still not seeing this, no matter how many times I pick a date for either field.

comment:4 Changed 6 years ago by tj.vantoll

Status: newpending

I am not either, what browser are you using @sadashiv?

comment:5 Changed 6 years ago by k_borchers

I am also unable to reproduce in latest Chrome and Canary.

comment:6 Changed 6 years ago by Scott González

Resolution: worksforme
Status: pendingclosed

@tj: In the original post, he said he was using Chrome.

Closing since several team members are unable to reproduce.

Note: See TracTickets for help on using tickets.