Opened 6 years ago

Closed 6 years ago

#9600 closed bug (duplicate)

Choosing the year 1AD...99AD in the year dropdown does not work

Reported by: schwarzenneger Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Create a datepicker with changeYear dropdown and an yearRange which starts from 1 using the following code (http://jsfiddle.net/XHQkG/1/):

$("#datepicker1").datepicker({
    changeYear: true,
    yearRange: "1:2020"
});

When you attempt to select the year 1 through 99 in the year dropdown, the year 1901 through 1999 becomes selected instead (1 becomes 1901, 2 becomes 1902 and so on). It works OK for years >= 100.

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7098.

Note: See TracTickets for help on using tickets.