Opened 7 years ago

Closed 7 years ago

#9614 closed bug (duplicate)

Draggable Dialogs are not positioning accurately in scrollable content areas

Reported by: anastos Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

In IE and Firefox, when a dialog widget has been opened and is set to be draggable, the dialog will drag accurately under the user's cursor when it is in a scrollable content area that has not been scrolled. When the content area has been scrolled, clicking to select and drag the dialog will immediately cause the dialog to jump out of position by an offset amount. For example, the dialog might jump 400 pixels away from the user's cursor and then drag from that new erroneous position. It appears that the dialog's position is not being accurately calculated through the entire chain of parent and child offset position values when the dialog element is dragged.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9315.

Note: See TracTickets for help on using tickets.