Opened 7 years ago

Closed 7 years ago

#9615 closed bug (duplicate)

Changing dialog focus causes iframe inside it to reload

Reported by: tasso85 Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

In our web applications we open "popups" by putting an iframe inside a dynamically generated dialog, which has this structure:

<div>
  <iframe src="whatever"></iframe>
</div>

Now, the problem is that, if there are multiple popup opened, when one in the background gains focus, all the other dialogs that are "put" behind it have their iframe reloaded!

This happens using version 1.10.3 but did NOT happen in version 1.8.23, from which we just upgraded, while we are still using jQuery 1.7.2

In the fiddle at http://jsfiddle.net/sKJmU/1/ if you click che button twice you'll open up two "popups", try to place them so that they partially overlap, and then change focus from one to the other, you'll see it triggers a refresh.

If you do the same test here http://jsfiddle.net/LuAhj/1/ you'll see it does not happen.

I would say this is a breaking change which I did not see documented anywhere, and suggest to revert to previous behaviour.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9166.

Note: See TracTickets for help on using tickets.