Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9616 closed bug (wontfix)

Clicking on a dialog does not bring it to the front

Reported by: tenor Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

If you have multiple dialogs in different containing divs, then clicking on one dialog does not bring it in front of others.

The bug can be reproduced at http://jsfiddle.net/TRe2y/

It's necessary to place dialogs in different containers if you are working with scoped themes and you want the dialogs to have different themes.

This bug didn't occur in jQuery UI 1.9.2

Change History (6)

comment:1 Changed 6 years ago by Scott González

Resolution: wontfix
Status: newclosed

By appending the dialog to a different container, you're opting into a new set of rules. Dialogs only stack within their containers. You also don't need to use containers for theming, that's why the dialogClass option exists.

comment:2 Changed 6 years ago by tenor

Thanks for looking into this quickly.

When working with scoped themes, you do need to put the dialog within a container.

Here's a fiddle that shows the difference between a dialog within a scoped container and one that was created with the dialogClass option: http://jsfiddle.net/TRe2y/1/

Is there a workaround for this issue?

comment:3 Changed 6 years ago by Scott González

Here's a reduced fiddle: http://jsfiddle.net/TRe2y/3/

This is really an issue with scopes not working directly on elements: https://github.com/jquery/download.jqueryui.com/issues/145

comment:4 Changed 6 years ago by tenor

Looks like I'll have to write custom code to handle the z-indexing. This worked okay in previous versions.

comment:5 Changed 6 years ago by Scott González

Luckily you can just override _moveToTop() and implement whatever you want :-)

comment:6 in reply to:  5 Changed 6 years ago by tenor

Thanks Scott. I'll look into that. :)

Note: See TracTickets for help on using tickets.