Opened 7 years ago

Closed 7 years ago

#9667 closed bug (duplicate)

Resizable with helper loses 1px

Reported by: kuz Owned by:
Priority: minor Milestone: none
Component: ui.resizable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Resize with helper via side handle causes losing 1px from the other side (Example http://jqueryui.com/resizable/#helper - Try to resize width with handle-e and you will lose 1px height. Same in other direction: resizing handle-s steals 1px from width).

The reason is in defining height and width of the helper in _renderProxy function in jquery.ui.resizable.js.

  this.helper.addClass(this._helper).css({
    width: this.element.outerWidth() - 1,
    height: this.element.outerHeight() - 1,
    position: "absolute",
    left: this.elementOffset.left +"px",
    top: this.elementOffset.top +"px",
    zIndex: ++o.zIndex //TODO: Don't modify option
  });

Posible solution is to remove decreasing of outer-size in this part.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9547.

Note: See TracTickets for help on using tickets.