Opened 6 years ago

Closed 5 years ago

#9680 closed bug (duplicate)

position.collision 'flip' does not work with autocomplete

Reported by: romario333 Owned by: romario333
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

I set autocomplete's position collision option to 'flip'. It is not respected however, flipping just does not happen.

See this plunkr for the demo:

http://plnkr.co/edit/HRgLYZYDKg0PnoetVkUY?p=preview

I have tested this on several browsers (Chrome 31, Firefox 25 and IE 10) and they are all affected.

It seems to be caused by this commit:

7f808b2047725cd8fde51a948cb4e5f5946c82e1, Position: Check to also make sure to only flip if more of the element is inside "within"

If I revert this commit, 'flip' starts to work correctly.

Change History (5)

comment:1 Changed 6 years ago by Scott González

Owner: set to romario333
Status: newpending

That link is working just fine for me. Tested in Chrome 30.

Version 1, edited 6 years ago by Scott González (previous) (next) (diff)

comment:2 Changed 6 years ago by romario333

Status: pendingnew

So suggestions were shown above the text inputs in your case? For both fields? (The right one is actually hacked to work correctly).

comment:3 Changed 6 years ago by Scott González

Status: newopen

Now I see that there's a problem if the space gets small enough. It flips for a while, but then stops.

comment:4 Changed 6 years ago by Scott González

Description: modified (diff)

comment:5 Changed 5 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #8710.

Note: See TracTickets for help on using tickets.