Opened 6 years ago

Closed 6 years ago

#9699 closed bug (duplicate)

Dialog position offsets during drag on Firefox

Reported by: mvalle Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

I have an accordion from which a button on each tab opens a Dialog.

On Firefox (latest version Win 7 64 bits) the following annoying bug appears. This does not happen with Chrome. BTW: jQuery 2.0.3 jQueryUI 1.10.3

If the tab is visible on the initial screen, the dialog appears and I can drag it around the screen without problems.

But if I have to scroll-down the accordion to reach the tab I'm interested in, then the dialog appears but as soon as I start dragging it around, the dialog springs downward by a fixed amount that seems equal to the amount I scrolled the accordion upward. And this offset between the mouse and the dialog title bar remain fixed even if I try to click again on dialog title bar.

One example is available on the forum (http://forum.jquery.com/topic/dialog-position-offsets-during-drag-on-firefox) to reproduce the problem. Unzip it and look at index.html with Firefox. Open one tab and click on the icon. The dialog opens and has no problem to be dragged around. Now reach the last tab. Do the same and watch the dialog position offsets your mouse.

The suggestion done elsewhere to add a position: {...} option to the dialog does not change anything for me.

Thanks for your help! mario

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9315.

Note: See TracTickets for help on using tickets.