Opened 6 years ago

Closed 4 years ago

#9700 closed bug (wontfix)

Dialog: Enter key does not submit form in IE8 with more then one input field and submit input

Reported by: straszakm Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsbin.com/AyiTASAQ/1/

According to specs, if form has more then one text input field and if there is a submit input field, then a form should be submitted on Enter keypress. And it is. But not when using dialog() in IE8 (it is fine when dialog() is not used).

Change History (2)

comment:1 Changed 6 years ago by tj.vantoll

Status: newopen
Summary: Enter key does not submit dialog form in IE8 with more then one input field and submit inputDialog: Enter key does not submit form in IE8 with more then one input field and submit input

Very odd. I confirmed that the same form submits when not in a dialog and that this works fine in IE9+.

comment:2 Changed 4 years ago by Scott González

Resolution: wontfix
Status: openclosed

Since we've discontinued support of IE 8, we won't be fixing this.

Note: See TracTickets for help on using tickets.