Opened 8 years ago

Closed 5 years ago

#9721 closed bug (fixed)

Menu: Submenu vertical position not fitted properly

Reported by: tenor Owned by:
Priority: minor Milestone: 1.11.3
Component: ui.menu Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Submenus on a menu that's positioned to the bottom of a page are not displayed such that the menu flows upward so that menu items are visible.

This is repro'd at http://jsfiddle.net/RBh7w/ .Here you can see that the 'Light' submenu flows upwards properly and the menu items are visible. However, the 'Dark' menu flows downwards and the menu items cannot be seen (it also causes the page to be extended).

I'm unable to repro this using the JQuery UI menu example at http://jsfiddle.net/2VJVy/ . Is this because there are a smaller number of items on that menu?

Change History (5)

comment:1 Changed 8 years ago by tj.vantoll

Status: newopen
Summary: Submenu vertical position not fitted properlyMenu: Submenu vertical position not fitted properly

Confirmed and reduced against master: http://jsfiddle.net/tj_vantoll/rCx7M/. I'm not exactly sure what's going wrong here.

comment:2 Changed 8 years ago by tj.vantoll

For some reason the position utility's flip collision detection is not adjusting the position when it seems like it should. If I crank the font-size way down this works as expected: http://jsfiddle.net/tj_vantoll/rCx7M/2/.

comment:3 Changed 8 years ago by tenor

It seems like after a certain height or number of items (in this case 14), the vertical fitting is not performed or fails. See http://jsfiddle.net/rCx7M/1/ . Uncomment the extra items to confirm.

comment:4 Changed 8 years ago by Scott González

Likely caused by #8710.

comment:5 Changed 5 years ago by Scott González

Milestone: none1.11.3
Resolution: fixed
Status: openclosed
Note: See TracTickets for help on using tickets.