Opened 6 years ago

Closed 6 years ago

#9725 closed bug (duplicate)

Changing Focus on dialogs will cause a div scroll bar to scroll to the top position

Reported by: gallogjj Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Here is the fiddle

http://jsfiddle.net/F8qGb/3/

Basically there are 2 dialogs. One contains a div with overflow-y and a fixed height (to make it scrollable)

Steps to Reproduce 1) Got http://jsfiddle.net/F8qGb/3/ 2) On the "Scroll Me First" dialog, scroll down partially or completely 3) Click on the "Click Me Next" dialog 4) Look at the scroll bar on "Scroll Me First" and notice that the scroll bar is now at the top

This issue does not exist in jquery ui 1.9.2 but appears in 1.10.3 (I didn't try others)

Reproduced on Chrome and Firefox

Walking through the chrome debugger, it occurs during an "OnBlur" callback. During which the dialog disappears, then re-appears but with the scroll bar reset.

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9166.

Note: See TracTickets for help on using tickets.