Opened 6 years ago

Closed 5 years ago

#9728 closed bug (wontfix)

Slider: Scroll Demo - screwed up on window resize

Reported by: csinfosystems Owned by:
Priority: minor Milestone: none
Component: ui.slider Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

http://jqueryui.com/slider/#side-scroll

Leave scroll bar in center (or just away from ends of scroll pane) and re-size browser window down (smaller), then move bar handle to some place other than at ends of scroll length, then re-maximize. Try sliding handle. Repeat whole process until on re-maximize the scroll bar handle will not slide the entire length of the scroll pane but seems to have "padding" at the left and the right of the horizontal scroll length. As repeat, problem gets worse ( "padding" gets larger and larger on left and right scroll length, so available scrollable length gets smaller and smaller).

Change History (2)

comment:1 Changed 6 years ago by tj.vantoll

Component: ui.coreui.slider
Status: newopen
Summary: Slider: Scroll Demo - Sliding Length Available Gets Smaller on Repeated Browser Window "Restore Down and then Re-Maximize"Slider: Scroll Demo - screwed up on window resize

Thanks csinfosystems.

This is easier to see on the demo resource directly: http://jqueryui.com/resources/demos/slider/side-scroll.html.

Something about this window.resize() handler isn't working as intended: https://github.com/jquery/jquery-ui/blob/a343d83a4268d35b9072b3092b079248a86545ca/demos/slider/side-scroll.html#L87.

Last edited 6 years ago by tj.vantoll (previous) (diff)

comment:2 Changed 5 years ago by Scott González

Resolution: wontfix
Status: openclosed

We decided to just delete that demo since it isn't something people should be doing. This is gone in master and will be gone from jqueryui.com with the next release.

Note: See TracTickets for help on using tickets.