Opened 6 years ago

Closed 6 years ago

#9767 closed bug (duplicate)

v 1.10.2+ Problem with input fields on jqgrid dialogs

Reported by: scuenca Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a jqgrid table that is open inside a dialog. This table opens another dialog with an input text to filter data. With the version 1.9.2 of jquery-ui it works fine (see http://jsfiddle.net/IrvinDominin/zdACB/). But if you change the version of jquery-ui for the 1.10.2 for example, the input text of the second dialog (the filter dialog) is not editable, but not disabled.

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Component: ui.coreui.dialog
Resolution: duplicate
Status: newclosed

Duplicate of #9087.
This is a duplicate of #9087.

You can get this working with this extension:

$.widget( "ui.dialog", $.ui.dialog, {
	_allowInteraction: function( event ) {
		return !!$( event.target ).closest( ".ui-jqdialog" ).length || this._super( event );
	}
});

See http://jsfiddle.net/tj_vantoll/zdACB/1/.

Note: See TracTickets for help on using tickets.