Opened 7 years ago

Closed 7 years ago

#9773 closed bug (duplicate)

jQuery UI Sortable Placeholder appears off-by-one when dragging from connected sortable

Reported by: MeoMix Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

I'm using the edge version of jQuery and jQuery UI provided through CodePen.io. At time of writing, that's jQuery 1.10.2 and jQuery UI 1.9.2

I am on the Beta channel of Google Chrome, 33.0.1750.46 beta-m, but another StackOverflow user is able to reproduce the issue on the latest version of Google Chrome 32.0.1700.76

The operating system is Windows 7.

Here's a codepen to reproduce the issue: http://codepen.io/anon/pen/sjFHe Here's a screencast of the issue reproducing itself: http://screencast.com/t/cAV6xYXWUO

Here's a stackoverflow post with confirmation from a second user and an OK workaround: http://stackoverflow.com/questions/21225033/jquery-ui-sortable-placeholder-appears-in-incorrect-position-but-only-on-first/21387617?noredirect=1#21387617

I am seeing the placeholder for a sortable appear at index + 1 when it should be appearing at index. This only occurs the first time the dragged element enters the droppable area. If the dragged item moves out and then back in, the placeholder appears correctly.

Is this a known issue?

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #9314.
This is fixed in master. See http://codepen.io/tjvantoll/pen/uHDIr.

Note: See TracTickets for help on using tickets.