Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9802 closed bug (duplicate)

slider cursor may never be released

Reported by: matteosistisette Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Steps to reproduce:

  1. go to http://jqueryui.com/slider/#colorpicker
  2. click and drag one of the sliders, e.g. the green one
  3. while keeping the mouse button pressed, move all the way to the left and beyond
  4. when the mouse cursor is way outside of the slider and outside of the rectangle that contains the example, release the mouse

Expected: the slider cursor should be releaded Observed: the slider cursor remains bound to mouse movements as if you hadn't released the mouse button.

It's quite unbelievable that there is such a basic bug that is visible even in the demo.

Change History (2)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8912.

comment:2 Changed 6 years ago by janicki

Please see my note on #8912, and consider reopening one of these.

Note: See TracTickets for help on using tickets.