Opened 5 years ago

Closed 3 years ago

#9816 closed bug (wontfix)

[IE9] IE9 crash with dialog and hide()

Reported by: xlefebvre Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I've found a bug that makes IE9 crash. It happens when you create a dialog with a span (with a style="float:left"), and an input next to him, then you use attr('something',).hide(), IE9 crashes. I know that there is a lot of conditions, but I tried to remove some of those conditions one by one and each time,it makes the code work again.

IE9 information: Version9.0.8112.16421 Update Versions: 9.0.22 Windows 2008 R2

Here is the code on jsFiddle: http://jsfiddle.net/UkK27/1/

Here is the full code to put in html file:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Test crash IE9</title>
    <script src="//code.jquery.com/jquery-1.11.0.js" type="text/javascript"></script>
    <script src="//code.jquery.com/ui/1.10.4/jquery-ui.js" type="text/javascript"></script>
    <link href="//code.jquery.com/ui/1.10.4/themes/smoothness/jquery-ui.css" rel="stylesheet" type="text/css" />
</head>
<body>
    <div id="dialog-container">
        <span style="float: left;">myLabel</span>
        <input type="text" id="myInput" />
    </div>
    <script type="text/javascript">
        $(function () {
            $('#dialog-container').dialog({
                buttons: [{
                    text: 'Crash',
                    click: function () {
                        $('#myInput').attr("title", '');
                        $('#myInput').hide();
                    }
                }]
            });
        });
    </script>
</body>
</html>

Another input:

  • IE10 and IE11 seems to work fine with this code.

Change History (4)

comment:1 Changed 5 years ago by tj.vantoll

Wow this is insane, but I was able to recreate it. Any additional information you can provide to reduce this would be helpful. I'm going to try to dig into this a little more later.

comment:2 Changed 5 years ago by xlefebvre

Hi,

Thanks for the quick reply, we've done additional tests on other servers, this is what we've get:

Crashes:
Windows 2008 R2 IE9 Update version: 9.0.12
Windows 2008 R2 IE9 Update version: 9.0.16
Windows 2008 R2 IE9 Update version: 9.0.22

Doesn't crash:
Windows 2008 IE9 Update version: 9.0.15
Windows 2008 IE9 Update version: 9.0.19

What's your version to reproduce the bug, windows 7 ?

Version are the same 9.0.8112.16421

Maybe this is related to Windows 2008 R2 ?

If you think of a workaround in the meantime, I'm interested

Last edited 5 years ago by Scott González (previous) (diff)

comment:3 Changed 5 years ago by tj.vantoll

I'm at a loss. I can consistently recreate the problem on IE9 on a Windows XP VM and Windows Vista machine, but I cannot recreate this on BrowserStack. I also cannot reduce this test case in any meaningful way, and I can't debug what might be going wrong because... when you open IE9's developer toolbar - the example doesn't crash!

comment:4 Changed 3 years ago by Scott González

Resolution: wontfix
Status: newclosed

Since we've discontinued support for IE 9, we won't be fixing this.

Note: See TracTickets for help on using tickets.