Opened 6 years ago

Closed 3 years ago

#9906 closed bug (worksforme)

Tooltip: Delegating from document removes text in title element

Reported by: A_Johansen Owned by: A_Johansen
Priority: minor Milestone: none
Component: ui.tooltip Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Using tooltip widget with document as selector removes text in <title></title> when the tooltip widget is disabled.

Change History (8)

comment:1 Changed 6 years ago by A_Johansen

This might not be a bug, but using document as a selector is directly shown in an example in the tooltip widget page, which might lead to this problem for anyone trying to use it.

Last edited 6 years ago by A_Johansen (previous) (diff)

comment:2 Changed 6 years ago by tj.vantoll

Owner: set to A_Johansen
Status: newpending

Hi A_Johansen,

Thanks for taking the time to contribute to jQuery UI. I'm not seeing this behavior as it appears the title is left in place: http://jsfiddle.net/tj_vantoll/MQV5m/. Can you please alter my test case to show the problem you're experiencing.

comment:3 Changed 6 years ago by A_Johansen

Status: pendingnew

I don't know how to do it in jsfiddle, but it is the <title> THIS TEXT DISAPPEARS </TITLE> in the header that is affected and not the title attribute in a div or so.

comment:4 Changed 6 years ago by tj.vantoll

Status: newpending

I don't think I understand. If you're talking about the <title> tag, you can view that in your dev tools of choice on jsFiddle, and it is not altered in my test case. We need to see this problem before we can do anything about it.

comment:5 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:6 Changed 5 years ago by Scott González

Resolution: invalid
Status: closedreopened

comment:7 Changed 5 years ago by Scott González

Status: reopenedopen
Summary: Using tooltip widget with document as selector removes text in title tagTooltip: Delegating from document removes text in title element

comment:8 Changed 3 years ago by Scott González

Resolution: worksforme
Status: openclosed

I can't reproduce this in 1.10.4, 1.11.4, or 1.12.0.

Note: See TracTickets for help on using tickets.