Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#9977 closed bug (wontfix)

Problem with modal dialog opened when focusing on text input

Reported by: michelgeny Owned by: michelgeny
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

I use a form with a read-only text input. The script calls the dialog open method to display a UI modal dialog when the user clicks in the input text field. The dialog opens normally, but on close the dialog disappears, and not the overlay. For now the only solution consists to create the dialog when the focus event occurs and invoke the "destroy" method for closure. Tested on Mac OS 10.9.2 with FF 28.0, Safari 7.0.3, Chrome 34.0.1847.116 See demo: http://jsbin.com/goxul/1/edit?html,output

Change History (4)

comment:1 Changed 6 years ago by Scott González

Owner: set to michelgeny
Status: newpending

You're essentially caught in a loop. When a dialog closes, it puts focus back where it was before the dialog opened. Showing a dialog when an element gains focus isn't really good UX. What are you trying to accomplish?

comment:2 Changed 6 years ago by michelgeny

Status: pendingnew

Thanks for your answer. My goal was to bring up a list of enumerated values ​​loaded dynamically to allow a user choice. The same dialog should allow, if necessary, modify or add one or more values ​​in the enumeration. I think I'll just put a button for opening the dialogue and forget the triggering focus.

comment:3 Changed 6 years ago by Scott González

Resolution: wontfix
Status: newclosed

That would be a lot less jarring for the user.

comment:4 Changed 5 years ago by Scott González

#10593 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.