Opened 6 years ago

Closed 6 years ago

#9996 closed bug (patcheswelcome)

Tooltip: Mouse-based fade in shows tooltip element before animation starts in IE8

Reported by: Jörn Zaefferer Owned by:
Priority: minor Milestone: none
Component: ui.tooltip Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Looking at the default demo in IE8, using the mouse ends up showing the tooltip elements fully, then starts the face animation. Already happens in 1.10.4, so not a regression. This only happens when using the mouse, not when tabbing to fosuable elements.

Change History (3)

comment:1 Changed 6 years ago by Jörn Zaefferer

Status: newopen

Also happens for the custom-style demo, which looks pretty awful in IE8. In addition, the text of the tooltip is shown at the end of the page while the tooltip itself is visible. The text there stays when the tooltip closes.

comment:2 Changed 6 years ago by Jörn Zaefferer

All of the tooltip demos suffer the same problem as described above.

In addition, the tooltips in the video player demo are just a white box with no visible border or text.

comment:3 Changed 6 years ago by Scott González

Resolution: patcheswelcome
Status: openclosed

We reduced the amount of time that the element is visible as much as we could, but joern.zaefferer was still seeing the flash. Since nobody else has complained about this in the one and a half years this behavior has existed, we're going to close as patches welcome.

Note: See TracTickets for help on using tickets.