Ticket #3094 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

dialog button pane

Reported by: ajpiano Owned by: rdworth
Priority: major Milestone: 1.7
Component: ui.dialog Version: 1.5.1
Keywords: dialog buttonpane Cc:
Blocking: Blocked by:

Description

The buttonpane is getting covered up by the main content as of 1.5.1, at least in FF3

The problem seems to be on line 83 where the position is set to absolute.

.addClass('ui-dialog-buttonpane').css({ position: 'absolute', bottom: 0 });

Setting position to relative got the buttons to show up, though I'm not really sure how deep the rabbit hole goes on this one, so I'm not sure if just changing that is the ideal solution.

Change History

comment:1 Changed 6 years ago by scott.gonzalez

  • Owner changed from scott.gonzalez to rdworth
  • Status changed from new to assigned

comment:2 Changed 6 years ago by kmoss

This change comes from #3094 and seems to be caused by the aforementioned bottom: 0 overriding the value given to the bottom propety by the themes.

comment:3 Changed 6 years ago by kmoss

Sorry, I meant #3061.

comment:4 Changed 6 years ago by Cloudream

  • Milestone set to 1.6

seems buttons are in front?

comment:5 Changed 6 years ago by Cloudream

  • Priority changed from blocker to major

comment:6 Changed 6 years ago by scott.gonzalez

  • Status changed from assigned to closed
  • Resolution set to fixed

This should be fixed with new CSS framework. Feel free to re-open this ticket if you continue to have problems after 1.6rc3 with a new theme.

Note: See TracTickets for help on using tickets.