Ticket #5380 (closed bug: fixed)

Opened 4 years ago

Last modified 2 years ago

Position Demo breaks when dragging an element

Reported by: kswedberg Owned by:
Priority: minor Milestone: 1.8.19
Component: ui.position Version: 1.8
Keywords: Cc:
Blocking: Blocked by:

Description

 http://ui-dev.jquery.com/demos/position/

Using FF3.6 Mac.

To reproduce, drag the "to position" element. The "to position 2" element jumps to the far bottom-right corner (with scrollbars).

Possible cause: The offset is being calculated and set based on the assumption that the demo is in an iframe. However, it looks like with the new layout, the demo is just in a div.

Change History

comment:1 Changed 2 years ago by joern.zaefferer

  • Status changed from new to open
  • Component changed from [meta] ui.demos to ui.position

Still an issue.

comment:2 Changed 2 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.9

comment:3 Changed 2 years ago by Scott González

  • Status changed from open to closed
  • Resolution set to fixed

Position: Simplify default demo by removing drag functionality on positioned elements. Fixes #5380 - Position Demo breaks when dragging an element.

Changeset: 6da7278e879c0dc734c23231a71fdd92f7a57a0c

comment:4 Changed 2 years ago by Scott González

Position: Simplify default demo by removing drag functionality on positioned elements. Fixes #5380 - Position Demo breaks when dragging an element. (cherry picked from commit 6da7278e879c0dc734c23231a71fdd92f7a57a0c)

Conflicts:

demos/position/default.html

Changeset: f01db5d8a1321d9f5d8f270aa79ef49574dffaed

comment:5 Changed 2 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.19
Note: See TracTickets for help on using tickets.