Ticket #5882 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

UI.Sortable .sortable( "cancel" ) call the this._mouseUp method without param

Reported by: tobias.istvan Owned by:
Priority: minor Milestone: 1.8.9
Component: ui.sortable Version: 1.8.2
Keywords: sortable cancel Cc:
Blocking: Blocked by:

Description

The .sortable( "cancel" ) call the this._mouseUp without param. For the _mouseUp method require this param.

Also:

  • not check the existing of the this.placeholder in the condition
  • not check the existing of the this.domPosition in the condition

Change History

comment:1 Changed 4 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Sortable: pass a fake event object to _mouseUp on cancel. Fixes #5882 - UI.Sortable .sortable( cancel ) call the this._mouseUp method without param. (cherry picked from commit cf0c32f335479d00224d69f3c5ff53d147a6a8e6)

Changeset: 465c4c2cbef33fc4491d862245180b6441875c15

comment:2 Changed 4 years ago by Scott González

Sortable: pass a fake event object to _mouseUp on cancel. Fixes #5882 - UI.Sortable .sortable( cancel ) call the this._mouseUp method without param.

Changeset: cf0c32f335479d00224d69f3c5ff53d147a6a8e6

comment:3 Changed 4 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.8.9

comment:4 Changed 4 years ago by scott.gonzalez

#5055 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.