Ticket #6030 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

ui.dialog with jQuery 1.3.2 causes RangeError

Reported by: jeffsmith Owned by:
Priority: minor Milestone: 1.8.7
Component: ui.dialog Version: 1.8.4
Keywords: Cc:
Blocking: Blocked by:

Description

I've run across an issue when using jQuery 1.3.2 and ui.dialog (1.8.4). The combination of the two seems to trigger a recursion error:

Safari 5.0.1: "RangeError: Maximum call stack size exceeded." jquery.min.js:12 Firefox 3.6.8: "too much recursion." jquery.min.js:12

I have a test case available here:  http://examples.furtherahead.com/jquery-ui/modal-1.3.2.html

Change History

comment:1 Changed 3 years ago by scott.gonzalez

#6689 is a duplicate of this ticket.

comment:2 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Dialog: Moved the default value for the position.of option inside the _position() method to avoid a bug in jQuery 1.3.2. Fixes #6030 - ui.dialog with jQuery 1.3.2 causes RangeError.

This should be reverted in jQuery UI 1.9.

Changeset: 22671ad4f8e3e2e921c27bd2933fa088950abf2f

comment:3 Changed 3 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.8.7

comment:4 Changed 3 years ago by Scott González

Revert "Dialog: Moved the default value for the position.of option inside the _position() method to avoid a bug in jQuery 1.3.2. Fixes #6030 - ui.dialog with jQuery 1.3.2 causes RangeError."

This reverts commit 22671ad4f8e3e2e921c27bd2933fa088950abf2f.

Changeset: 0e15f573d6f1d5c138ce63d2a462737dbb874faa

Note: See TracTickets for help on using tickets.