Ticket #6102 (closed enhancement: fixed)

Opened 4 years ago

Last modified 2 years ago

Datepicker: Add Portuguese localization

Reported by: cim Owned by:
Priority: minor Milestone: 1.8.6
Component: ui.datepicker Version: 1.8.5
Keywords: Portuguese initialisation Cc:
Blocking: Blocked by:

Description

There doesn't seem to be a Portuguese (as opposed to Portuguese-Brazilian) initialisation for datepicker. I would like to contribute the following code:

/* Portuguese initialisation for the jQuery UI date picker plugin. */
/* Based on the Brazilian initialisation */
jQuery(function($){
	$.datepicker.regional['pt'] = {
		closeText: 'Fechar',
		prevText: '<Anterior',
		nextText: 'Seguinte',
		currentText: 'Hoje',
		monthNames: ['Janeiro','Fevereiro','Março','Abril','Maio','Junho',
		'Julho','Agosto','Setembro','Outubro','Novembro','Dezembro'],
		monthNamesShort: ['Jan','Fev','Mar','Abr','Mai','Jun',
		'Jul','Ago','Set','Out','Nov','Dez'],
		dayNames: ['Domingo','Segunda-feira','Terça-feira','Quarta-feira','Quinta-feira','Sexta-feira','Sábado'],
		dayNamesShort: ['Dom','Seg','Ter','Qua','Qui','Sex','Sáb'],
		dayNamesMin: ['Dom','Seg','Ter','Qua','Qui','Sex','Sáb'],
		weekHeader: 'Sem',
		dateFormat: 'dd/mm/yy',
		firstDay: 0,
		isRTL: false,
		showMonthAfterYear: false,
		yearSuffix: ''};
	$.datepicker.setDefaults($.datepicker.regional['pt']);
});

Change History

comment:1 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Summary changed from Portuguese initialisation for datepicker to Datepicker: Add Portuguese localization
  • Resolution set to fixed
  • Milestone changed from TBD to 1.9

Fixed in  23b569f.

comment:2 Changed 4 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.6

comment:3 Changed 4 years ago by Scott González

Datepicker: Added Portuguese localization. Fixes #6102 - Datepicker: Add Portuguese localization.

Changeset: 23b569f46ec7472d4baec7486d27ddbe5aaa8518

comment:4 Changed 2 years ago by scott.gonzalez

#7979 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.