Ticket #6174 (closed bug: fixed)

Opened 4 years ago

Last modified 23 months ago

Mouse: 1.4.3rc2 breaks interactions for some markup

Reported by: squix Owned by:
Priority: critical Milestone: 1.8.6
Component: ui.mouse Version: 1.8.5
Keywords: Cc:
Blocking: Blocked by:

Description

Bug in: 1.4.3rc2 / jQuery UI incompatibility

If you use helper: 'clone' option in draggable, you'll notice a strange behavior, first the draggable starts dragging with the mouse, then it stops then if you release the mouse the draggable still stays until you "click" it returns if you have the revert option.

Steps to reproduce, create a $(el).draggable with the following options:

addClasses: false, appendTo: 'body', scroll: false, revert: 'invalid', helper: 'clone', cursor: 'pointer',

If you remove the helper:'clone' it works as normal!

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to worksforme

Works for me in Chrome dev, Firefox 3.6, Safari 5, Opera 10.62, IE 6.

comment:2 in reply to: ↑ 1 Changed 4 years ago by squix

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Replying to scott.gonzalez:

Works for me in Chrome dev, Firefox 3.6, Safari 5, Opera 10.62, IE 6.

Investigated some more, turns out the issue is when the draggable is a "link". Only Chrome seems to be affected, works normally in mozilla.

So again, to reproduce: (Tested in Chrome 6)

<a class="mylink" href="javascript:void(0);">My title</a>

$('.mylink').draggable({

addClasses: false, appendTo:'body', revert:'invalid', helper:'clone', zIndex: 500

});

If you remove the helper:"clone" option it works as normal. Again jQuery 1.4.2 does not have this issue so there seems to be something going on in Chrome, and jQuery 1.4.3rc1/2

comment:3 Changed 4 years ago by scott.gonzalez

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from 1.4.3rc2 breaks draggable with "helper-clone" option to Mouse: 1.4.3rc2 breaks interactions on anchors
  • Component changed from ui.draggable to ui.mouse
  • Milestone changed from 1.next to 1.9

Fixed in  a829697.

comment:4 Changed 3 years ago by scott.gonzalez

  • Summary changed from Mouse: 1.4.3rc2 breaks interactions on anchors to Mouse: 1.4.3rc2 breaks interactions for some markup

comment:5 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.6

comment:6 Changed 3 years ago by scott.gonzalez

#6650 is a duplicate of this ticket.

comment:7 Changed 3 years ago by Scott González

Mouse: Always call event.preventDefault() in _mouseDown if we've met the starting conditions. Fixes #6174 - Mouse: 1.4.3rc2 breaks interactions on anchors.

Changeset: a829697d0c9083438bde3a2e47964c29bfbc9417

comment:8 Changed 3 years ago by scott.gonzalez

#6846 is a duplicate of this ticket.

comment:9 Changed 23 months ago by scott.gonzalez

#5678 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.