Ticket #6242 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Button .enable() strange behavior on Webkit (Google Chrome, Safari)

Reported by: morozov Owned by:
Priority: minor Milestone: 1.8.14
Component: ui.button Version: 1.8.1
Keywords: button enable blur Cc:
Blocking: Blocked by:

Description

If to enable a button right before it's clicked, it seems to be disabled.

A way to reproduce:

  • open attached file
  • put cursor to the text input
  • click the button


the "click" event was not fired

Attachments

webkit-button.html Download (785 bytes) - added by morozov 4 years ago.
Demo

Change History

Changed 4 years ago by morozov

Demo

comment:1 Changed 4 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.9

comment:2 Changed 3 years ago by danbhfive

  • Milestone changed from 1.9 to 1.8.10

this is a valid bug, here is the test case:  http://jsbin.com/ohene4

It looks like it was resolved in 1.8.10

comment:3 Changed 3 years ago by danbhfive

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 3 years ago by scott.gonzalez

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone 1.8.10 deleted

I still see the problem in 1.8.10 (and 1.8.11).

comment:5 Changed 3 years ago by scott.gonzalez

  • Status changed from reopened to open
  • Milestone set to 1.9

comment:6 Changed 3 years ago by danbhfive

My mistake. Looks like if you click the edge of the button, it works. But if you click the text, it doesn't work. plot thickens...

comment:7 Changed 3 years ago by dougneiner

This problem is caused by the call to _resetButton that was triggered as a result of changing the disabled option.

Fix here:  https://github.com/jquery/jquery-ui/pull/256

Demo here:  http://jsbin.com/ohene4/9

comment:8 Changed 3 years ago by Scott González

  • Status changed from open to closed
  • Resolution set to fixed

Merge pull request #256 from dcneiner/button-blur

Fixed #6242

Changeset: dd00f7f3b4ebfa8d2df6119148bf5120721d3abc

comment:9 Changed 3 years ago by Doug Neiner

Button: no longer calls _resetButton() after changing the disabled option. Fixed #6242 - Button .enable() strange behavior on Webkit (Google Chrome, Safari) (cherry picked from commit 8df834f68c4337cb6d128360c76a4621f050bd60)

Changeset: 3842fa9f948283fa4bab9a99ad8d0a8a2adcc175

comment:10 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.14
Note: See TracTickets for help on using tickets.