Ticket #6692 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Autocomplete: ui-autocomplete-loading class not removed when Ajax request times out

Reported by: doerwalter Owned by:
Priority: minor Milestone: 1.8.7
Component: ui.autocomplete Version: 1.8.6
Keywords: Cc:
Blocking: Blocked by:

Description

When the autocomplete source function does an Ajax request with a timeout value, and the request exceeds the timeout limit, the ui-autocomplete-loading CSS class will never get removed from the input control.

Change History

comment:1 Changed 3 years ago by scott.gonzalez

  • Status changed from new to open
  • Summary changed from ui-autocomplete-loading class not removed when Ajax request times out to Autocomplete: ui-autocomplete-loading class not removed when Ajax request times out

comment:2 Changed 3 years ago by Scott González

  • Status changed from open to closed
  • Resolution set to fixed

Autocomplete: Handle ajax errors and timeouts. Fixes #6692 - Autocomplete: ui-autocomplete-loading class not removed when Ajax request times out.

Changeset: 40135bb09130a56aabc0d185b62a597cb45df0dc

comment:3 Changed 3 years ago by doerwalter

Changeset 40135bb09130a56aabc0d185b62a597cb45df0dc fixes the problem for the simple case, i.e. when the source option is the ajax URL. However when the source options is not a string, but a function, the problem isn't fixed. I realize that it might be unfixable without any changes to the API, but at least there should be a way to cancel the autocomplete (e.g. by calling response(null)) and it should be documented that response *must* be called even in case of an error/timeout.

comment:4 Changed 3 years ago by scott.gonzalez

I've updated the docs.

comment:5 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.7
Note: See TracTickets for help on using tickets.