Ticket #6775 (closed bug: fixed)

Opened 4 years ago

Last modified 2 years ago

DatePicker remains open when tabbing out

Reported by: postb99 Owned by:
Priority: minor Milestone: 1.8.13
Component: ui.datepicker Version: 1.8.7
Keywords: Cc:
Blocking: Blocked by:

Description

Hello,

I stumbled upon the following behavior and applied the proposed fix :

 http://forum.jquery.com/topic/close-datepicker-when-input-loses-focus

In my case, I use JQuery 1.3.2, and when I tab from one form field to another one (in fact, out of the text input a datepicker is atteched to), I may have a datepicker calendar remain open, but not at its normal place : at the top left corner of my browser window, as if it was orphaned. It seems related to how fast I tab between fields.

Change History

comment:1 Changed 3 years ago by k_borchers

I have sent a pull request at  https://github.com/jquery/jquery-ui/pull/218.

Thanks

comment:2 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Merge pull request #218 from kborchers/bug_6775

Datepicker: Moved the setting of _datepickerShowing to after postProcess. Fixed #6775

Changeset: 476777f1e926d56547291abda642683513f92610

comment:3 Changed 3 years ago by Scott González

Datepicker: Moved the setting of _datepickerShowing to after postProcess to prevent being able to tab away leaving the datepicker open. Fixed #6775 - DatePicker remains open when tabbing out

Changeset: 73602652acd6908acaad27c29a5e3562e7538b5b

comment:4 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.13

comment:5 Changed 2 years ago by mikesherov

#5524 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.